17/02/21

Attivare l’avviso di chiamata su ho. Mobile

Articoletto veloce veloce…Aranzulla mode ON 🙂
Dopo anni di gestori telefonici “importanti” sono passato a ho mobile.
Mi sono trovato benissimo sia a livello di prezzi che come copertura del segnale (alla fine e’ Vodafone). Da subito però ho riscontrato la presenza di un grosso difetto. Con il mio Xiaomi Redmi non riuscivo ad attivare l’avviso di chiamata. Questo servizio e’ per me molto importante, e non poterlo usare era un problema.
Con il semplice comando *43# mi diceva che il servizio era attivo ma effettivamente non funzionava!!

Continua a leggere

29/04/20

Linux e processori sempre al minimo

Scrivo queste due righe molto velocemente, dopo 2 giorni passati ad impazzire dietro un Lenovo Thinkpad e l’installazione di un sistema operativo adatto alle sue caratteristiche.
Serve a mia figlia per poter seguire le lezioni scolastiche e partendo da una installazione di Lubuntu decido di dare un aspetto più accattivante al tutto.

L’utilizzo di piattaforme specifiche per ambito scolastico mi fa puntare l’attenzione su un windows 10 moooolto Lite.
Installo il tutto…perdo 1gg solo di aggiornamenti e installazioni software (non ha disco SSD)….per poi ritrovarmi stranamente con il processore che non supera mail il 50% delle sue potenzialità!

Già parliamo di un Core2Duo del 2020…..se poi resta frenato al 50% diventa inutilizzabile
Cerco qua e la…molti hanno il mio stesso problema…ma non mi soffermo più di tanto….windows 10 non riconosce la webcam usata….torniamo a linux.

Abbandono Lubuntu…leggerissimo ma troppo scarno…e mi sposto su Mint XFCE.

Giusto compromesso tra leggerezza e aspetto. In più considero Mint una distribuzione già pronta in tutto e per tutto Out of the Box.

Anche qui….processore al 50%.
O meglio…Htop me lo da al 100% ma alla metà della sua frequenza massima.

Il suo stepping permette di oscillare tra 1 e 2 Ghz…..e lui se ne sta sempre fermo a 1 Ghz.

Ci ho sbattuto la testa per 2gg….arrivando infine alla soluzione!

Il bios (!??!?!?!?!?!?) diceva a linux che poteva si variare la frequenza, ma tra 1 Ghz e 1Ghz!!!!! Quindi lui stava a??? 1 GHZ!

C’e’ un impostazione Bios_limit, che non sono riuscito a modificare in nessun modo, che dice al sistema che deve stare in quei valori e non ci si puo’ spostare da li.

Ma…..alla fine ….la soluzione!!!!
Posso impostare all’avvio un parametro del Kernel che gli dice di ignorare le impostazioni dettate dal bios.

Basta aggiungere la voce “processor.ignore_ppc=1” (senza virgolette) alla linea di caricamento del kernel (di solito in Grub).

Riavvio il sistema e’ ….tahhh  dahhhh….tutto funziona alla grande e processore sfruttato al 100%.